Como usar uma versão de PHP diferente para cada site no IIS

Para quem nunca passou por isso deve pensar: para que usar uma versão antiga do PHP? Passa tudo para a versão mais recente. Mas a solução pode não ser simples assim. Este servidor tem várias aplicações importantes para os usuários, mas como algumas foram escritas há um bom tempo, a versão mais nova do PHP não compila eles direito, tem tags e funções extintas, que dão excessão ou mensagens de alerta o tempo todo.

A solução tem que ser esta mesmo: instalar várias versões do PHP. Isso pode ser feito na unha, mas felizmente uma boa alma desenvolveu o PHP Manager for IIS. Esse programa cria um atalho dentro de cada pasta na adminstração do IIS, e com uma interface gráfica te permite escolher a versão e as extensões habilitadas para cada diretório.

Printscreen

Printscreen

Isso pode ser útil para testes também porque as vezes o servidor não vai estar na mesma configuração que o seu localhost.

Referência:
http://phpmanager.codeplex.com/

Deixe uma resposta

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s